[solved] Redox as Virtualbox Guest - did not boot - 0000:9A00


#1

Hello,
i like to try redox.
Created a Virtual Machine in Virtualbox 5.0.16 r10871
Run the installer, reboot.

Then the system hang with:

loadig
000F#0040
0000:9A00

http://postimg.org/image/dwke9vzjd/

if i use: Windows 10 (32bit) as System
then i got

Condition: 5 in a endless loop

http://postimg.org/image/u6i1x5x8h/


#2

I merged in some things that may fix these issues, make sure you choose AHCI instead of IDE for the Storage configuration.

The changes will be available when this build completes:
https://jenkins.redox-os.org/job/Redox/66/


#3

works fine, thank you!


#4

Hi kafka82,
can you share your Virtualbox Settings an Version please ?
Thanks

I have:
General:

Basic: Typ Linux, Version Ubuntu (32bit)

System:
Chipset: PIIX3

Ponting device: USB-Tablet

mass storage:

Controller: SATA (Typ AHCI)
HDD SATA-PORT 0

Controller: IDE
sec. Master: CD-ROM

USB:

USB 2.0-Controller (EHCI)

now it boots, keyboard work, but no mouse ( tryed: PS/2 and USB-Tablet )

thanks


#5

Use ICH9 chipset and PS/2 mouse


#6

thanks x1596357, this works for me!


#7

Use ICH9 chipset and PS/2 mouse

I merged in some things that may fix these issues, make sure you choose AHCI instead of IDE for the Storage configuration.

I’m glad there was a post on this, I was having trouble the past few days running the virtualbox image found at https://static.redox-os.org/ using the default settings in virtualbox but was finally able to run it today. Thanks


#8

Just found this project - amazing work! Starting up the VM using VirtualBox under Windows, I had no mouse. Here is what I discovered:

In VB settings, if I select Network - Attached to Bridged Adapter, then I have to uncheck System - Enable PAE/NX. If I select Network - Attached to NAT, then I have to check System - Enable PAE/NX. If either of these combinations is incorrect, then the VM has no mouse. I stumbled upon this because I automatically change Network to Bridged Adapter for all new VMs.

Either way, Redox doesn’t appear to have connectivity to the outside world. Not a complaint, I understand development is in early stages.

Thanks.


#9

What do you mean?
http://www.redox-os.org/news/the-internet-on-redox/


#10

Thank you for the reply, and for the link to the YouTube video. I’m running VirtualBox 5.0.30 under Windows 7 64-bit. I’ve configured the Redox VM as described. Redox is starting up for me, but networking appears not to be working. Following the video, I attempt to do “sudo pkg install sodium” in Terminal. It responds with “Connecting to static.redox-os.org:80”, and that’s it.

Switching to the debug terminal, I see about 12 lines of DHCP activity. The last couple lines are:

DHCP: Domain Name Server: [192, 168, 1, 1, 71, 252, 0, 12]
DHCP: Lease Time: …
DHCP: Server ID: [10, 0, 2, 2]
DHCP: New IP: 10.0.2.15
DHCP: New Subnet: 255.255.255.0
DHCP: New Router: 10.0.2.2
DHCP: Sent Request
DHCP: Ack IP: [10, 0, 2, 15], Server IP: [10, 0, 2, 4]

And that’s it. The DNS values are being pulled from the Windows host session, and are correct. 192.168.1.1 is my home router.

If anyone has Redox with networking working in VirtualBox under Windows, I’d appreciate if you could share your configuration.

Thanks!


#11

I was having an issue mentioned above when running in VirtualBox: no mouse movement, even though keyboard was working fine. Instead of the settings mentioned above, nothing worked until I changed it to this:

  • Chipset: PIIX3
  • Pointing Device: PS/2 Mouse
  • Disable PAE/NX

I understand this project is still in its early stages, but I’m curious about the apparent changes in virtual device support; these are not the same settings detailed in earlier posts… Has there been some change in what Redox supports?


#12

Actually, it looks like I was wrong… now, it works with PAE/NX enabled. It seems to have been somewhat random, though… I reset the VM several times to test with different resolutions (as at first it seemed to not work with higher resolutions) but now it’s working pretty consistently on all resolutions I’m testing.


#13

#14

Finally figured out my issue with networking with Windows 7 and VirtualBox. I had to switch the chipset from ICH9 to PIIX3. Set network up to use NAT. Now it is working fine.