Make all fail when compiling fuse


#1

I’m trying to build Redox with newest rustc 1.10.0-nightly, but I’m experiencing some troubles with fuse crate. Does anyone have the same problem or do you have any idea how to solve this?

This is output of make all with RUST_BACKTRACE=1

Compiling fuse v0.2.7
error: failed to run custom build command for `fuse v0.2.7`
Process didn't exit successfully: `/home/user/redox/crates/redoxfs/target/debug/build/fuse-903ac6b64e7fdf04/build-script-build` (exit code: 101)
--- stderr
thread '<main>' panicked at 'called `Result::unwrap()` on an `Err` value: "`\"pkg-config\" \"--libs\" \"--cflags\" \"fuse\"` did not exit successfully: exit code: 1\n--- stdout\nPackage fuse was not found in the pkg-config search path.\nPerhaps you should add the directory containing `fuse.pc\'\nto the PKG_CONFIG_PATH environment variable\nNo package \'fuse\' found\n"', ../src/libcore/result.rs:785
stack backtrace:
   1:     0x562962f18ed0 - std::sys::backtrace::tracing::imp::write::h9fb600083204ae7f
   2:     0x562962f1f6fb - std::panicking::default_hook::_$u7b$$u7b$closure$u7d$$u7d$::hca543c34f11229ac
   3:     0x562962f1f383 - std::panicking::default_hook::hc2c969e7453d080c
   4:     0x562962f0ed6f - std::sys_common::unwind::begin_unwind_inner::h30e12d15ce2b2e25
   5:     0x562962f10318 - std::sys_common::unwind::begin_unwind_fmt::hb2de8a9968d38523
   6:     0x562962f18291 - rust_begin_unwind
   7:     0x562962f559df - core::panicking::panic_fmt::h257ceb0aa351d801
   8:     0x562962efb4d5 - core::result::unwrap_failed::hb1ced490f1c4ca85
                        at ../src/libcore/macros.rs:29
   9:     0x562962efaaae - _<std..result..Result<T, E>>::unwrap::hb772e7d8964e902e
                        at ../src/libcore/result.rs:723
  10:     0x562962ef9678 - build_script_build::main::he5071e1b00fcfe0e
                        at /home/user/.cargo/registry/src/github.com-88ac128001ac3a9a/fuse-0.2.7/build.rs:12
  11:     0x562962f1efc4 - std::sys_common::unwind::try::try_fn::h04c0c89e4add6cc4
  12:     0x562962f1821b - __rust_try
  13:     0x562962f1ea0b - std::rt::lang_start::h61f4934e780b4dfc
  14:     0x562962efb769 - main
  15:     0x7f2afc25782f - __libc_start_main
  16:     0x562962ef92e8 - _start
  17:                0x0 - <unknown>

Makefile:544: recipe for target 'build/i386-unknown-redox/debug/filesystem.bin' failed

Is this a problem with rustc?

Thanks in advance for any ideas.


#2

You need to install libfuse-dev on linux or osxfuse on mac


#3

Thanks! I was finally able to run my brainf* interpreter inside Redox :smile:


#4

Having a similar problem on Debian Jessie x64, and I have libfuse-dev installed so it’s not that. Here’s the output-

error: failed to run custom build command for fuse v0.2.8
process didn’t exit successfully: /home/shaka/MyFiles/Computers/Redox/redox_source/redox/target/release/build/fuse-c78f48a8df66bd1f/build-script-build (exit code: 101)
— stderr
thread ‘main’ panicked at ‘called Result::unwrap() on an Err value: Command { command: ““pkg-config” “–libs” “–cflags” “fuse””, cause: Error { repr: Os { code: 2, message: “No such file or directory” } } }’, /checkout/src/libcore/result.rs:859
note: Run with RUST_BACKTRACE=1 for a backtrace.

mk/filesystem.mk:2: recipe for target ‘build/filesystem.bin’ failed
make: *** [build/filesystem.bin] Error 101


#5

you must install pkg-config


#6

Thank you bungcip, now it compiled without error. :slight_smile: but… when I run make qemu, qemu runs up to a message “no bootable device.”

I’m just going to document my progress here (if that’s ok) in the hope that it might help others…

I don’t see a .iso file after “make all”.
In the “build” folder I have filesystem.bin and hardrive.bin.
So, I ran “make iso” and it compiled up to error of missing “isohybrid” command.
But!
It did create “livedisk.bin” successfully in the “build” folder, which ran in qemu with Vesa video card.
And!
I was able to put it on a usb drive and it loaded sucessfully on my laptop.
Sweet!

So the moral of the story thus far is, the “make iso” command built “redox/build/livedisk.bin” which you can use in vm, burn and boot from.


#7

you need genisoimage & isohybrid package in order to build iso in ubuntu. I alread filled the issue here: https://github.com/redox-os/redox/issues/928