Install Redox tool-chain on fedora 27


#1

I’m trying to build Redox on my Fedora 27 machine, but it failed with the message,

main thread panicked. Do you have x86_64-unknown-gcc installed?

For that, I googled and found .deb packages but they don’t seem to work. I tried to build the libc from source, but pulling the whole repository is quite big. Still downloaded, I’m running into one issue to another.

So I’m looking for a way to install Redox tool-chain or you can suggest me any other method to start with Redox on fedora.


#2

I ran into the same problem on solus. What I ended up doing was using qume to create a server install of Ubuntu with about 20gb disk space.

There is also instructions to build with a docker image but I never got that to work.


#3

Right now, I’m in front of my PC trying to build it using Docker. The problem is, I don’t have any idea of what’s going on and what will I end up getting. I think your idea with a temporary Ubuntu VM is great. Though I’m still looking for a workaround.