Cannot boot iso in qemu

I am trying to boot the latest ISO in qemu but the boot process hangs after an “EDID not supported” message. Here is the sequence of steps I followed to boot the iso and install Redox to an virtual hard drive…

qemu-img create -f qcow2 redox.hdd 1G
qemu-system-x86_64 -cdrom redox-installer_2.iso  -hda redox.hdd

This boots to a Linux prompt where I ran redox-installer and installed Redox to /dev/sda and rebooted. But the boot process hangs as described above.

I thought perhaps booting from IDE is not supported hence I switched to a SATA HDD using …

qemu-system-x86_64 \
      -drive file=redox.hdd,if=none,id=mydisk \
      -device ich9-ahci,id=ahci \
      -device ide-drive,drive=mydisk,bus=ahci.0 \
      -cdrom redox-installer.iso

but nothing changed.

I get the same error after running ‘make qemu’ except that it asks me to continue. After pressing y, the system boots normally. Here’s the full error, if anyone’s interested:

Does anyone know what causes this?

I built Redox today (May 1st 2016) and got the same warning when QEMU launches. It looks like EDID is typically used to tell graphics cards what kind of displays a system has (

Orbital looks fine, but I am not famliar enough with the GUI to know if QEMU is displaying something incorrectly.

Looking into QEMU a bit further, it sounds like the emulator does not provide valid EDID data for its virtualized display: