Always black screen when boot in VBOX

#1

ISO: redox_0.3.4.iso (download from github)
Virtual Box: version 5.1.28

screen stays black after pressed ‘Y’ as follow

there are some settings of VM

cpu-core: 1
memory: 512MB
chipset: PIIX3
mouse: USB Tablet
I/O APIC not enabled
EFI not enabled
HardwardClock enabled
PAE/NX enabled
VT-x/AMD-V enabled
Nested Paging enabled

Is anyone can help me?

0 Likes

#2

I’m running that version, under the latest VirtualBox on Windows 7 64-bit. I have:

General 
   Basic
      Type: Other
      Version: Other/Unknown (64-bit)
   Advanced
      Shared Clipboard: Disabled
      Drag'n Drop: Disabled

System
   Motherboard
      Base Memory: 4096 MB
      Chipset: PIIX3
      Pointing device: PS/2 Mouse
      Extended features
         Enabled I/O APIC: Yes
         Enable EFI: No
         Hardware Clock: No
   Processor
      Processors: 4
      Extended features
         Enabled PAE/NX: Yes
   Acceleration
       Paravirt: KVM
       Hardware Virtutalization
          Enable VT-x/AMD-V Yes
          Enable Nested Paging NO

Hope this helps.

0 Likes

#3

thank you for your reply.
I successfully booted Redox by modifying the memory to be greater than 1G.

0 Likes

#4

I have exactly the same error with the latest VirtualBox (5.2.18) and Redox (0.3.5) on Windows 10
I have reserved 2GB memory for the VM but still doesn’t work

1 Like

#5

I am newbie here. Tried both 0.3.5 and 0.3.3 same issue.
After looking into above thread, tried to play with ICH9, PIIX3 and also the Storage controller to SATA. But no luck. Anyone can help?

0 Likes

#6

Same issue on real hardware.

0 Likes

#7

Same issue here VirtualBox 6, Windows 10 Pro x64

0 Likes

#8

If you faced that type of problem then you will do one thing just reset the device and by doing this you will see the problem will be solved.

hp printer error code oxc4eb827f

0 Likes

#10

My Configuration:
Linux KDE Neon 18.04

For work, test this configuration using RedoxOS 0.5:
General:

Type: Other
Version: Other/Unkdown (64-bit)

System:

Memory: 2048 MB
Chipset: ICH9
Mouse: PS/2 Mouse
I/O APIC: Enabled
EFI: Enabled
Hardward Clock in UTC Time: Disabled
Processors: 1
PAE/NX: Enabled
Acceleration:

VT-x/AMD-V: Enabled
Nested Paging: Enabled

Display:

Video Memory: 32MB
Graphics Controller: VBoxVGA(On Linux)
Acceleration: Enable 3D Acceleration

Storage(Very Important):

Controller: SATA

Set type your units to: AHCI

Audio: Disabled

Network: Disabled or Enabled

Serial Ports: Disabled

USB controller: Disabled(Preferred)

Running VirtualBox on X11 is better;
Running VirtualBox on XWayland is very bug;

0 Likes